503 won't run

A place for all your Diablo Rouge Questions or just a place to shoot the bull about those little Red Devils.

503 won't run

Postby Rock » Sun Feb 21, 2010 9:59 pm

Hi

I've been trying to start my 503 this week-end with my Brother. Gas won't go to the carb . We look at the needle and it was stuck so we put some w40 on it. But still won't run. It had a new Diaphram install when i bought it. Even when we put gas straight in the carb it won't run or gas won't get into the carb from the hose. We tried about 4 spart blugs and still the same thing. I'm just about to blow my fuse on these Diablo. :D LOL

My step son was able to start it last week, just by playing with the gas handle . It din't run very long because the gas is not going to the carb .

Take care
Rock
Hus-ski 200A
65 Snowbug
73 Olympique 300
71 Snow Cruiser
196? Rat Hus-ski
User avatar
Rock
 
Posts: 414
Joined: Sun Feb 24, 2008 8:00 am
Location: 84 A Byng Ave Kapuskasing,Ontario P5N 1w8

Re: 503 won't run

Postby Barrie2777 » Mon Feb 22, 2010 9:34 pm

When ever I get into these crazy situations I first remove the plug and check for spark: second, if there is spark,remove the drive belt, put gas down the carb. It should fire. If it puffs smoke, then it is flooded so hold the throttle open while cranking. It should fire now. If it runs good, if not then check the height of the lever arm...it should be level with the base of the carb or just slightly above it. This position reduces the amount of pressure it exurts on the needle. If the low speed needle is too lean, it will be hard to start. Make sure it is turned out 1-1/4 turns. Adjust inward after the engine starts and has warmed up to operating temp.
User avatar
Barrie2777
 
Posts: 1460
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: 503 won't run

Postby Rock » Mon Feb 22, 2010 9:55 pm

The first thing that we did on the 503 was checking the plug on it. Their was spark so we tried to started but still not running. then we put some gas in the carb and still nothing. After awhile i had the gas handle wide open and still nothing . We change spark plugs and put more gas in the carb and still not running. I might just bring the carb to my mechanic and change everything . This might help. The Hus-ski's are so very easy then the Diablo's :D LoL

I had the 500 for over 2 years and i never had a good ride with it because it's very hard to start or it won't run for long.

Mayby i should bring them to you Barrie and you could fix them for me. I'll be going to Ste-Gabriel de Brandon in April to get the body of a 600 with a single track . I could go by your house and drop them off . LOL

Tks again for your help

Rock
Hus-ski 200A
65 Snowbug
73 Olympique 300
71 Snow Cruiser
196? Rat Hus-ski
User avatar
Rock
 
Posts: 414
Joined: Sun Feb 24, 2008 8:00 am
Location: 84 A Byng Ave Kapuskasing,Ontario P5N 1w8

Re: 503 won't run

Postby Barrie2777 » Tue Feb 23, 2010 8:17 am

Ste Gabriel de Brandon has one of the largest vintage rides in this province with hundreds of machines on the ride. Too bad it is over for this year.
User avatar
Barrie2777
 
Posts: 1460
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: 503 won't run

Postby Rock » Tue Mar 02, 2010 9:11 pm

Hi there

Yesterday i put in a new plug and there it started put 1 pull but gas is still now going in the carb . I'll be changing the needle sometime this week and see if it will make a difference .

Rock

Barrie

How far is Ste-Gabriel -De- Brandon for your place?
Hus-ski 200A
65 Snowbug
73 Olympique 300
71 Snow Cruiser
196? Rat Hus-ski
User avatar
Rock
 
Posts: 414
Joined: Sun Feb 24, 2008 8:00 am
Location: 84 A Byng Ave Kapuskasing,Ontario P5N 1w8

Re: 503 won't run

Postby Barrie2777 » Tue Mar 02, 2010 10:08 pm

I am north west of Ste Gabriel de Brandon, near Mt Tremblant.
User avatar
Barrie2777
 
Posts: 1460
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: 503 won't run

Postby Rock » Mon Jul 19, 2010 8:11 am

Hi all

After working on the 503 Saturday for about 3 hours could not get it running. I took the carb apart and could not fine anything wrong with. So on Sunday bought a new plug still not running or gas won't go to the carb. So i decide to change the gas filter on the carb . After drinking a cold PEPSI :D I decide to try starting the old 503 And it started right away . Now all i need is a carb adjusment .

After looking at the old gas filter there was a small crack at the bottom. I've been working on the 503 on and off for over a month and could not figger out the problem and all it was a the gas filter. I'm very glad that it's working good now.

This weekend on going to the LumberJack Festival in Town so i'm going to bring my 503 , 200a , 600 , 444 and mayby my Snowbug . Also i might bring the Diablo movie that Bruce made and let it play all day . It should be very interesting to see people and their stories.

Take care
Rock
Hus-ski 200A
65 Snowbug
73 Olympique 300
71 Snow Cruiser
196? Rat Hus-ski
User avatar
Rock
 
Posts: 414
Joined: Sun Feb 24, 2008 8:00 am
Location: 84 A Byng Ave Kapuskasing,Ontario P5N 1w8


Return to Questions & Discussions about Diablos

Who is online

Users browsing this forum: No registered users and 1 guest

cron