Page 1 of 1

502 not shutting down

Posted: Thu Nov 12, 2020 8:05 pm
by Steve502
Hi I’m new to the forum
I have a 502 and at the end of last season it stopped shutting off with the key so I had to choke it to stop the engine. I was wondering if it could be a ground problem
Any help on this would be appreciated
Thanks

Re: 502 not shutting down

Posted: Sat Nov 14, 2020 10:43 am
by myoldhus-ski
Hello Steve: Your switch grounds the magnito so the engine will stop. If turning the key off doesn't do that you have a broken wire or ground wire not conected any more. Inspect the wiring looking for a borken wire. The Ignition wire is often the brown one. If you jumper the brown wire back to the engine,it should stop the engine.The motor has to be grounded to the frame if the switch grounds to the frame. The switch may have failed. A simple test of the switch is to short across the termianals of the switch when the engine is running. If the engine stops the switch is the problem.

Re: 502 not shutting down

Posted: Sun Nov 15, 2020 4:45 pm
by Schoobytwo (Bruce)
Appreciate myoldhus-ski trying to help. I'll add a few comments.

The brown wire on the Hirth is the motor ground and the black wire goes to the points. Both these wires go to your key switch and when in the "Off" position, the key switch should provide continuity between the two and ground out the points thus shutting off the motor. The common place for failure is where the wires go into the 3-wire connection block under the heat shield. Often a wire will break and then you loose your circuit.

If you find a broken wire at this connector block, put a bit of solder on the wire end before reinstalling it. Without the solder, it will just break again.

Testing the key switch as suggested is a good idea too.

Let us know what you find.

Bruce

Re: 502 not shutting down

Posted: Mon Nov 16, 2020 8:33 pm
by Steve502
Thanks I will have a good look for a broken wire and test the switch. Let you know what I find

Re: 502 not shutting down

Posted: Thu Nov 19, 2020 6:43 pm
by Steve502
Thanks for your help. I found that the brown wire was out of the block and that was the problem. It is now back to normal and shuts off with the key
Can’t wait for snow :roll:

Re: 502 not shutting down

Posted: Tue Nov 24, 2020 9:58 am
by Schoobytwo (Bruce)
Those pesky brown wires! :lol:

A couple of comments about the grounding circuit in a Diablo;

The hood and the headlights are should have a separate ground wire running to them so the circuit is not trying to ground through the hood hinge. I like to use two wire quick connects at the hood and run a ground wire from the frame within the hood, through the quick connect and down to the chassis where the hood mount bolts to. Then from this connection, run it back to the motor recoil mounting bolt.
DSC05909-001.JPG
DSC05909-001.JPG (34.56KiB)Viewed 1377 times
At the key switch, I continue the brown ground wire down to the chassis where the handlebars mount and then continue this brown ground wire to the ski seater.
DSC05899-001.JPG
DSC05899-001.JPG (154.75KiB)Viewed 1377 times
At the ski seater, I run another two wire connect instead of the single wire. Expecting the ski seater to ground through the ball joint is lucky at best. Running a separate ground wire direct to the seater chassis assures a better tail light.
DSC04457.JPG
DSC04457.JPG (163.3KiB)Viewed 1377 times
Hope that helps,