model 600 restoration

Use this area to have discussions and swap information regarding Diablos or Hus Skis!

Re: model 600 restoration

Postby Barrie2777 » Sun Feb 04, 2018 5:23 pm

These carbs were originally set to have a "vertical pull" . With them flipped , a horizontal pull almost works but there is not enough lever action to activate the slave carb. I rivetted an "L" shaped piece to the throttle linkage. Now the horizontal pull of the HUSSKI system will activate both carbs. The pivoting attachment was robbed off a ramdom carb.
Attachments
extralever.jpg
extralever.jpg (137.91 KiB) Viewed 774 times
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby Barrie2777 » Sun Feb 04, 2018 5:33 pm

Just the choke lever to deal with....this one was meant to be adjusted manually....no cable. I removed the choke plate then slid out the choke rod...careful to not loose the ball and spring which keep it open. This part was slid on then reassemled the choke rod and plate.
Attachments
rod attachment.jpg
rod attachment.jpg (175.63 KiB) Viewed 774 times
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby Barrie2777 » Sun Feb 04, 2018 7:25 pm

Carb specs
Attachments
carb specs.jpg
carb specs.jpg (123.25 KiB) Viewed 769 times
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby Barrie2777 » Thu Feb 08, 2018 11:45 am

The muffler for the 600 is not fastened to the motor compartement. It is only securred to the motor.
Attachments
600mufflerinstalled.jpg
600mufflerinstalled.jpg (138.47 KiB) Viewed 753 times
600muffler.jpg
600muffler.jpg (149.06 KiB) Viewed 753 times
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby mkawski22 » Fri Feb 09, 2018 2:34 pm

Nice work, if I could figure out how to upload my pictures of my restoration I will. Barrie, do you have a list of materials and prints for your all purpose sled you built, I would like to build one
mkawski22
 
Posts: 8
Joined: Sat Aug 27, 2016 1:26 pm

Re: model 600 restoration

Postby Barrie2777 » Mon Feb 12, 2018 2:48 pm

I dont understand your question. Do you want a list of available parts?
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby Barrie2777 » Mon Feb 12, 2018 2:59 pm

Now was the time to see if it would run. It had great spark but i wanted to check the timing so i pulled the flywheel and disconnected the points to use the audible tester for when the points open. All was good so i put it all back together but this time no spark!! After concidering all possibilities i took it apart again, checked, back together...still no spark. All apart again but this time I checked the points connection only to find the outside insulating washer was missing. AHHHH! It had fallen off during the audible test. Back together and this engine runs.
Attachments
plasticpointswasher.jpg
plasticpointswasher.jpg (168.8 KiB) Viewed 728 times
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby Barrie2777 » Sun Sep 16, 2018 5:42 pm

What is wrong with this carb? Look closely.....
Attachments
double carb.jpg
double carb.jpg (231.07 KiB) Viewed 360 times
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Re: model 600 restoration

Postby myoldhus-ski » Sun Sep 16, 2018 8:05 pm

The aluminum seems worn on the right side. I also do not see and diaphragm parts. Jim
User avatar
myoldhus-ski
 
Posts: 63
Joined: Thu Jan 21, 2010 10:01 pm
Location: Poplar Point Manitoba

Re: model 600 restoration

Postby Barrie2777 » Mon Sep 17, 2018 6:16 am

This is the slave carb for my 600 with dual carbs. Im still trying to figure out why its doesnt function properly. I dismantled again and this time niticed no welsh plug where there usually is but.....since the slave carb has no low speed jet maybe there is no need for a welsh plug???
User avatar
Barrie2777
 
Posts: 1454
Joined: Tue Mar 04, 2008 9:17 pm
Location: Arundel Quebec

Previous

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

cron